Debian Security Advisory

DSA-5290-1 commons-configuration2 -- security update

Date Reported:
28 Nov 2022
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 1014960.
In Mitre's CVE dictionary: CVE-2022-33980.
More information:

Apache Commons Configuration, a Java library providing a generic configuration interface, performs variable interpolation, allowing properties to be dynamically evaluated and expanded. Starting with version 2.4 and continuing through 2.7, the set of default Lookup instances included interpolators that could result in arbitrary code execution or contact with remote servers. These lookups are:

  • script - execute expressions using the JVM script execution engine (javax.script)
  • dns - resolve dns records
  • url - load values from urls, including from remote server.

Applications using the interpolation defaults in the affected versions may be vulnerable to remote code execution or unintentional contact with remote servers if untrusted configuration values are used.

For the stable distribution (bullseye), this problem has been fixed in version 2.8.0-1~deb11u1.

We recommend that you upgrade your commons-configuration2 packages.

For the detailed security status of commons-configuration2 please refer to its security tracker page at: