Рекомендация Debian по безопасности

DSA-4972-1 ghostscript -- обновление безопасности

Дата сообщения:
10.09.2021
Затронутые пакеты:
ghostscript
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 994011.
В каталоге Mitre CVE: CVE-2021-3781.
Более подробная информация:

Было обнаружено, что Ghostscript, интерпретатор PostScript/PDF с лицензией GPL, неправильно выполняет проверку доступа для устройств ввода-вывода "%pipe%", "%handle%" и "%printer%", что может приводить к выполнению произвольного кода в случае обработки специально сформированного файла в формате Postscript (несмотря на включение песочницы с помощью параметра -dSAFER).

В стабильном выпуске (bullseye) эта проблема была исправлена в версии 9.53.3~dfsg-7+deb11u1.

Рекомендуется обновить пакеты ghostscript.

С подробным статусом поддержки безопасности ghostscript можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/ghostscript