Bulletin d'alerte Debian

DSA-4878-1 pygments -- Mise à jour de sécurité

Date du rapport :
27 mars 2021
Paquets concernés :
pygments
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 985574.
Dans le dictionnaire CVE du Mitre : CVE-2021-27291.
Plus de précisions :

Ben Caller a découvert que Pygments, un paquet de coloration syntaxique écrit en Python 3, utilisait des expressions rationnelles qui pourraient avoir pour conséquence un déni de service.

Pour la distribution stable (Buster), ce problème a été corrigé dans la version 2.3.1+dfsg-1+deb10u2.

Nous vous recommandons de mettre à jour vos paquets pygments.

Pour disposer d'un état détaillé sur la sécurité de pygments, veuillez consulter sa page de suivi de sécurité à l'adresse : https://security-tracker.debian.org/tracker/pygments.