Рекомендация Debian по безопасности

DSA-4715-1 imagemagick -- обновление безопасности

Дата сообщения:
02.07.2020
Затронутые пакеты:
imagemagick
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2019-13300, CVE-2019-13304, CVE-2019-13305, CVE-2019-13306, CVE-2019-13307, CVE-2019-15140, CVE-2019-19948.
Более подробная информация:

Данное обновление исправляет многочисленные уязвимости в Imagemagick. Различные проблемы работы с памятью, случаи отсутствующей или неполной очистки входных данны могут приводить к отказу в обслуживании, раскрытию содержимого памяти или выполнению произвольного кода в случае обработки специально сформированных файлов изображений.

В предыдущем стабильном выпуске (stretch) эти проблемы были исправлены в версии 8:6.9.7.4+dfsg-11+deb9u8.

Рекомендуется обновить пакеты imagemagick.

С подробным статусом поддержки безопасности imagemagick можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/imagemagick