Рекомендация Debian по безопасности

DSA-4640-1 graphicsmagick -- обновление безопасности

Дата сообщения:
15.03.2020
Затронутые пакеты:
graphicsmagick
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2019-19950, CVE-2019-19951, CVE-2019-19953, CVE-2019-11474, CVE-2019-11473, CVE-2019-11506, CVE-2019-11505, CVE-2019-11010, CVE-2019-11009, CVE-2019-11008, CVE-2019-11007, CVE-2019-11006, CVE-2019-11005, CVE-2018-20189, CVE-2018-20185, CVE-2018-20184.
Более подробная информация:

Данное обновление исправляет несколько уязвимостей в Graphicsmagick. Различные проблемы работы с памятью и случаи отсутствия или неполной очистки входны данных могут приводить к отказу в обслуживании, раскрытию памяти или выполнению произвольного кода при обработке специально сформированных файлов.

В предыдущем стабильном выпуске (stretch) эти проблемы были исправлены в версии 1.3.30+hg15796-1~deb9u3.

В стабильном выпуске (buster) эти проблемы были исправлены в версии 1.4~hg15978-1+deb10u1.

Рекомендуется обновить пакеты graphicsmagick.

С подробным статусом поддержки безопасности graphicsmagick можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/graphicsmagick