Debians sikkerhedsbulletin

DSA-4173-1 r-cran-readxl -- sikkerhedsopdatering

Rapporteret den:
16. apr 2018
Berørte pakker:
r-cran-readxl
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2017-2896, CVE-2017-2897, CVE-2017-2919, CVE-2017-12110, CVE-2017-12111.
Yderligere oplysninger:

Marcin Noga opdagede adskillige sårbarheder i readxl, en GNU R-pakke til læsning af Excel-filer (gennem det integrerede libxls-bibliotek), hvilket kunne medføre udførelse af vilkårlig kode, hvis et misdannet regneark blev behandlet.

I den stabile distribution (stretch), er disse problemer rettet i version 0.1.1-1+deb9u1.

Vi anbefaler at du opgraderer dine r-cran-readxl-pakker.

For detaljeret sikkerhedsstatus vedrørende r-cran-readxl, se dens sikkerhedssporingsside på: https://security-tracker.debian.org/tracker/r-cran-readxl