Debian Security Advisory

DLA-3257-1 emacs -- LTS security update

Date Reported:
31 Dec 2022
Affected Packages:
emacs
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2022-45939.
More information:

It was discovered that there was an issue in Emacs where where attackers could have executed arbitrary commands via shell metacharacters in the name of a source-code file.

This was because lib-src/etags.c used the system(3) library function when calling the (external) ctags(1) binary.

  • CVE-2022-45939

    GNU Emacs through 28.2 allows attackers to execute commands via shell metacharacters in the name of a source-code file, because lib-src/etags.c uses the system C library function in its implementation of the ctags program. For example, a victim may use the "ctags *" command (suggested in the ctags documentation) in a situation where the current working directory has contents that depend on untrusted input.

For Debian 10 Buster, this problem has been fixed in version 1:26.1+1-3.2+deb10u3.

We recommend that you upgrade your emacs packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS