Debian Security Advisory

DLA-2938-1 twisted -- LTS security update

Date Reported:
08 Mar 2022
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2022-21716.
More information:

It was discovered that there was an issue in the Twisted Python network framework where SSH client and server implementions could accept an infinite amount of data for the peer's SSH version identifier and that a buffer then uses all available memory.

  • CVE-2022-21716

    CVE-2022-21716: Twisted is an event-based framework for internet applications, supporting Python 3.6+. Prior to 22.2.0, Twisted SSH client and server implement is able to accept an infinite amount of data for the peer's SSH version identifier. This ends up with a buffer using all the available memory. The attach is a simple as `nc -rv localhost 22 < /dev/zero`. A patch is available in version 22.2.0. There are currently no known workarounds.

For Debian 9 Stretch, this problem has been fixed in version 16.6.0-2+deb9u2.

We recommend that you upgrade your twisted packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: