Debian Security Advisory
DLA-2132-1 libzypp -- LTS security update
- Date Reported:
- 03 Mar 2020
- Affected Packages:
- Security database references:
- In Mitre's CVE dictionary: CVE-2019-18900.
- More information:
It was discovered that there was an issue where incorrect default permissions on a HTTP cookie store could have allowed local attackers to read private credentials in libzypp, a package management library that powers applications like YaST, zypper and the openSUSE/SLE implementation of PackageKit
Incorrect Default Permissions vulnerability in libzypp of SUSE CaaS Platform 3.0, SUSE Linux Enterprise Server 12, SUSE Linux Enterprise Server 15 allowed local attackers to read a cookie store used by libzypp, exposing private cookies. This issue affects: SUSE CaaS Platform 3.0 libzypp versions prior to 16.21.2-27.68.1. SUSE Linux Enterprise Server 12 libzypp versions prior to 16.21.2-2.45.1. SUSE Linux Enterprise Server 15 17.19.0-3.34.1.
For Debian 8
Jessie, these problems have been fixed in version 14.29.1-2+deb8u1.
We recommend that you upgrade your libzypp packages.
Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS