Debian Security Advisory
DLA-2056-1 waitress -- LTS security update
- Date Reported:
- 01 Jan 2020
- Affected Packages:
- Security database references:
- In Mitre's CVE dictionary: CVE-2019-16789.
- More information:
It was discovered that there was a HTTP request smuggling vulnerability in waitress, pure-Python WSGI server.
In Waitress through version 1.4.0, if a proxy server is used in front of waitress, an invalid request may be sent by an attacker that bypasses the front-end and is parsed differently by waitress leading to a potential for HTTP request smuggling. Specially crafted requests containing special whitespace characters in the Transfer-Encoding header would get parsed by Waitress as being a chunked request, but a front-end server would use the Content-Length instead as the Transfer-Encoding header is considered invalid due to containing invalid characters. If a front-end server does HTTP pipelining to a backend Waitress server this could lead to HTTP request splitting which may lead to potential cache poisoning or unexpected information disclosure. This issue is fixed in Waitress 1.4.1 through more strict HTTP field validation.
For Debian 8
Jessie, these problems have been fixed in version 0.8.9-2+deb8u1.
We recommend that you upgrade your waitress packages.
Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS