Debian Security Advisory

DLA-1331-1 mercurial -- LTS security update

Date Reported:
30 Mar 2018
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 892964.
In Mitre's CVE dictionary: CVE-2018-1000132.
More information:

Mercurial version 4.5 and earlier contains a Incorrect Access Control (CWE-285) vulnerability in Protocol server that can result in Unauthorized data access. This attack appear to be exploitable via network connectivity. This vulnerability appears to have been fixed in 4.5.1.

This update also fixes a regression inroduced in 2.2.2-4+deb7u5 which makes the testsuite fail non-deterministically.

For Debian 7 Wheezy, these problems have been fixed in version 2.2.2-4+deb7u7.

We recommend that you upgrade your mercurial packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: